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                                     WARNINGS!

Modifying your vehicle can be very rewarding, but it also has the potential of leading to finan-
cial and emotional distress. The Hydra Nemesis ECU is no different- standalone engine man-
agement tuning is serious business! If you are not qualified to tune your vehicle, PLEASE seek 
out the assistance of a professional. The tech staff at FM will be happy to help as much as we 
can with installation and tuning via phone and email, but there are still a number of things that 
have to be done in person by you or a qualified professional. FM's base maps are good, but 
it is impossible to account for every variable there is. With that in mind, neither Flyin' Miata, 
Hydra EMS, nor Aquamist will be held responsible for the results of bad tuning or bad luck on 
the part of the end user.  Also, when street tuning, use either a co-pilot or the datalog feature 
in your laptop in order to make safe tuning changes. Please do not drive and tune at the same 
time!  We of course recommend dyno tuning for the best and safest results.

The Hydra ECU will not return OBD-II codes and is not CARB legal. The end user is 
responsible for determining if this system is legal for use on public roads in their state. 
By installing the Hydra EMS in your car you acknowledge and understand the aforemen-
tioned guidelines & recommendations. 
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Basic Info About the Hydra Nemesis Engine Management System

Congratulations on your purchase of the Hydra Nemesis EMS! This full standalone engine 
management system will allow you to tune your 90-05 Mazda Miata to its maximum potential. 
It incorporates tuning tools that assist in developing the best engine management map for 
your system, and also includes safety features that protect the engine from certain adverse 
situations. It will allow you to datalog and store map files using a laptop computer, which can 
then be used for tuning. This manual is a Miata installation & setup addendum to the current 
2.6.5 main manual from Hydra that is available on the CD you received, as well as at http://hy-
draems.com/. Please read and learn both for maximum insight on how to operate this 
system. The knowledge they contain will be integral to your success and/or the success 
of your tuner.

Parts List. The Hydra EMS system comes with the ECU box, an adaptor harness to interface 
the unit with your factory wiring, a serial cable for connecting the Hydra to your laptop comput-
er, a vacuum hose for sourcing the manifold absolute pressure (MAP) signal, a NTK lab-grade 
wideband oxygen sensor (WBO2), an air temp sensor (except MSM, optional), a mounting 
clip for the ECU, and a CD with the program file and Hydra main manual. 90-97 cars will also 
come with a knock sensor (99-05 Miatas have one from the factory). Optional items you may 
have purchased are a Serial -> USB converter cable for those who only have a USB port on 
their PC, larger fuel injectors if you are running more horsepower than your stock injectors can 
handle, an electronic boost control solenoid (PITA) or a manual boost controller (easy), and the 
Hydramist water injection system. Note- Contact FM for recommendations on spark plug heat 
range and gap. We recommend Magnecor wires and NGK plugs for all applications.

Installing the Hydra Nemesis Engine Control Unit

Location. Start by disconnecting the negative battery terminal. Then, locate the stock ECU. 
On U.S. spec vehicles it is: under the dash by the steering column on 99-05 cars; behind the 
passenger seat on 94-97 cars; and under the passenger's kick panel on 90-93 cars. Unplug 
the factory harness connectors. For 90-97 cars the Hydra will sit in the location that the fac-
tory ECU occupied using the supplied clip, so you'll need to remove the stock ECU. For 99-05 
cars take the adaptor harness and run it under the dash (above the transmission tunnel) such 
that the single connector end is on the driver's side and the three connector end is on the 
passenger's side. Then you'll mount the Hydra behind the glove box with the supplied bracket: 
on 99-00 cars the bracket mounts to a 6mm stud at the bottom, while on 01-05 cars it mounts 
to a 6mm stud at the top. To remove the glove box on the 99-05, open it and pull the right side 
towards the rear of the car. Once the right side pops out the left side will slide out.

Next (for all cars) plug the stock harness ends into the adaptor harness plug. Attach the se-
rial cable and run it out somewhere where it can be stashed normally but accessed for tuning. 
Leave the 3 plug side of the adaptor harness be for now- you'll have to pin in the WBO2 wires 
first, which will be described in the diagram on page 8 here, or page 17 of the Hydra main 
manual. Attach the MAP sensor hose to the barb on the Hydra and run it out to an appropriate 
signal source (vacuum nipple) on the intake manifold plenum. The source must be between 
the throttle body and head when looking at the direction of airflow- this way the Hydra 
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will see both vacuum and boost. This means no check valves inline! In fact, we don't recom-
mend sharing this MAP hose with anything other than a boost gauge. Note- This is the most 
important hose on the car! A failure, a leak, or a pinch here can cause poor running and pos-
sibly major engine damage. Please maintain this hose accordingly! 

MAF Removal. Because the Hydra uses an internal MAP sensor you can eliminate the factory 
mass air flow sensor on 94-05 cars (MAF) or the air flow meter on 90-93 cars (AFM) which im-
poses a restriction on your intake system. This sensor is located at the outlet of the factory air 
cleaner assembly. Remove this sensor if you want to increase the flow potential of your intake. 
If the removal of this unit creates a void that needs to be filled in your intake system, you will 
need to fabricate or purchase a pipe to take its place. Our FM2 turbo kits include a stainless 
steel delete pipe for the 94-05 MAF. The section of harness that went to the MAF can be tied 
back out of the way- it is no longer used. You may want to tape the end up to prevent a short 
since at least one wire is hot.

Upgrading from a Piggyback (optional). If you are upgrading to the Hydra from a Link piggy-
back engine management setup or some other brand of fuel and timing management, you will 
need to remove all of the fuel and timing management associated with that system and return 
the car in effect to stock. This will make the Hydra installation much more straightforward. 

Air Temp Sensor. The supplied Hydra air temp sensor will need to be mounted and wired in. 
(Except for 04-05 MSM cars that are using the factory turbo setup and FM intake- they can 
reuse the stock sensor. However, the Hydra ATS is much more responsive than the MSM unit 
so it may be worth a few more bucks to you if you can fabricate around the fact that they use a 
different thread pitch. the MSM unit is M10x1.25.) FM kits include a bung for the sensor; other 
systems will require you to fabricate a 3/8 NPT bung to mount the Hydra ATS. Note- With 99-
05 cars you could alternatively remove the upper intake manifold and drill / tap the hole in it. 

The Hydra ATS comes with a length of wire and two pins that must be 
crimped onto the wires and inserted in the plastic piece to form the 
connector. These metal pins must be crimped onto a wire and then 
slid into the plastic connector from the front side of the connector 
with the metal tab facing up. (see photo) Therefore, if you are using 
the factory wires and want a clean look you will need to slide the plas-
tic connector onto the wires before you crimp on the metal pins!

For wiring on the 99-05 Miata (except MSM) you will be using the two wires that go to the fac-
tory air temp sensor which was mounted in the stock airbox. Remove these wires and splice 
them into the connector that is provided with the new sensor. Note- if you may need to revert 
back to stock in the future, use spade connectors here to make the swap easier. The 99-05 
cars running on a stock ECU may not charge the battery without the factory ATS connected. 
If you have a MSM, the ATS that is mounted in the throttle body inlet pipe is already wired 
through the harness to the Hydra, and the other ATS in the stock airbox needs to be secured 
out of the way and is not used. 90-97 cars will require one wire from the supplied ATS run to 
chassis ground and the other (signal) wire to be connected to the power steering pump wire 
that runs across the front of the engine- it is blue with a yellow stripe and has a female bullet 
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connector at the end. Remove the wire from the pump and connect it to the ATS lead. If your 
car does not have this wire, you will need to run a flying lead back to D9 in the Hydra harness 
(Large blue, bottom row, position 9).

Fuel Injectors (optional). The factory fuel injectors will support up to around 200 rwhp on 
99-05 cars and around 160 rwhp on 90-97 cars, give or take, based on octane, induction type, 
and tuning. Note- the stock injectors are sufficient for naturally aspirated builds. The Hydra 
can control both high impedance (saturated) and low impedance (peak and hold) injectors 
with a change to the table at 2D Engine Calibration -> Injector Response. This injector dead-
time compensation is unique to different types of injector, and will affect starting, idle, and high 
vacuum cruising fuel values. FM will program the base map for your injectors, so it is important 
that we know what you are using. We supply low impedance 550cc injectors with our standard 
kits which can fuel up to around 300 rwhp on the stock fuel system with pump gas. For those 
who want more power, we can supply 750cc units which should get you over 400hp when 
matched with our complete high flow fuel system. Note- these boundaries may be extended 
with water injection. One other thing to consider is that if you plan on running E85 you'll need 
injectors that are at least 30% larger for the same HP level. 

To install the injectors on a 99-05 Miata, you will need to remove the upper portion of your in-
take manifold (including the throttle body) and your fuel rail. For the 90-97 Miatas, you will just 
need to remove the fuel rail and the hoses/ solenoids that are in the way. You will then need 
to splice the supplied pigtails for the injectors into the factory wiring (solenoids & injectors are 
non-polarized), or if you need to be able to put the car back to stock, we have plug and play 
injector harnesses available which are far easier. Note- After installing fuel injectors make sure 
to check for fuel leaks immediately after starting the car for the first time! Remember to use a 
light coating of oil on the upper O ring before pushing the injector into the rail to avoid a pinch. 
Also, cleaning out the lower seat area can prevent vacuum leaks on a fresh install. Be careful 
not not drop any debris into the engine through the holes while they are exposed!

Boost Control Solenoid (optional). If you are adding the Boost Control Solenoid it will need 
to be wired in and mounted. You will want to mount it on the frame of the car by the shock 
tower so the signal lines to the turbo will be short. On FMII cars, the air baffle is a convenient 
location and holes are provided. On MSMs, you may want to fabricate a spot on the plastic baf-
fle behind the driver's side headlight that holds a couple relays. The boost control solenoid has 
two wires which are non-polarized. One wire will go to a B+ (12v) source. The best place to 
get this is to T tap into the power wire in the diagnostics box located right in that area. Access 
the wires as they come out of the bottom of the box. In 90-97 Miatas it is the white wire with 
the red stripe. In 99-05 Miatas it is the black wire with the white stripe. (Both should be coming 
from the top right slot if you are looking down at the top of the diagnostics box while standing 
at the front of the car.) The other wire from the BCS will go to the Hydra where it will be con-
trolled by a switched ground. The Hydra adaptor harness runs this switched ground into the 
factory harness to make it easier to wire up- it leads into the harness to 
the wire that goes to the TEN terminal in the diagnostics box (right next 
to the B+ wire you already spliced into). Splice the ground wire from 
the BCS to the following wire (labeled TEN) coming out of the diagnos-
tics connector: 90-97 light green with a yellow stripe, 99-05 brown with 
a yellow stripe.



6

Note- if you want to have a switched high and low boost setting, install a toggle switch inline on 
the signal wire so that you can switch from mechanical base boost to electronically controlled 
boost. This wire goes to A5 (small blue plug, top row) at the Hydra. Your mechanical base 
boost should be at least 6 psi so that there is sufficient tension on the WG actuator. Your EBC 
pressure should be no more than around double your mechanical base boost for good control. 

The following is the vacuum hose routing to the Ingersol Rand FM BCS: attach the post-
compressor signal line to the EXH port; the nipple on the wastegate actuator to the OUT 
port; vent the IN port to atmosphere (or port it back in between your air filter and com-
pressor inlet). These labels are stamped into the BCS housing. Note- We have found that 
EBC in the Hydra is inconsistent. We now offer a Turbosmart manual boost valve that makes 
life much easier- this is included in FM2 kits.

Extra Wiring for 90-93 Cars. On 90-93 cars there are extra wires that need to be run.

1) We will be running the injectors in sequential since all 90-93 cars except 93 California cars 
run batch injection. (For the 93 CA cars you can skip this step and ignore the following fuel 
injector leads since the sequential wiring is already in place within the harness.) The flying lead 
from A7 (small blue, top row, position 7) will be run through the firewall to injector 3. (Injector 1 
is at the front of the engine and 4 is at the firewall.) Find the yellow wire going to injector 3 and 
cut it (leaving a pigtail in case you ever go back to stock). Connect the injector side of this wire 
to the flying lead from A7. Next, we will be doing the same thing for injector 4. The flying lead 
from the Hydra for injector 4 is coming from C16 (large blue, top row, position 16). Run it out to 
the yellow wire with a black stripe going to injector 4. Cut the Y/B wire and attach the injector 
side to the wire going to the Hydra.

2) In order to remove the AFM from the car you 
will also need to run the flying lead from A6 in the 
Hydra harness (small blue, top row, position 6) 
across the transmission tunnel to the light green 
wire in the fuel pump relay plug that is under the 
dash next to the steering column. (See photo) Cut 
this wire and splice all 3 leads back together us-
ing a heat-shrink butt connector.

3) (optional) Your 90-93 car comes with a 1 wire 
NBO2 that takes forever to warm up and seems 
to work inconsistently. If you want to install a better NBO2 you can purchase a 4 wire unit- we 
have them. (Although most people will just use the supplied WBO2..) Take the wire that went 
to your 1 wire unit, cut it, and splice it to the signal (black) wire on the 4 wire. The grey wire is a 
signal ground- you will need to run it to F11 (small grey, bottom row, position 11) at the Hydra. 
The two white wires are the heater element and polarity doesn't matter. Run one to chassis 
ground and the other to a switched 12v source. The blue single spade plug behind the driver's 
side headlight is an easy spot for switched power.

Note 1- The 90-93 cars have a unique fan / AC fan / AC relationship. The AC fan will not en-
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gage unless the AC is on. If you find your car overheating, or if you're doing a track day, unplug 
the harness from your AC clutch (under the hood) and turn on the AC button in the car- then 
you'll have both fans. If however your car does not have AC it's relatively easy to re-wire your 
fan relays so the Hydra can control them independantly, just like in 94-05 cars. 

Note 2- 90-93 manual transmission Miatas come with a TPS that's an on/off switch. With the 
Hydra you can install a linear TPS. Contact FM for the instructions. 

Knock Sensor. On 90-97 cars you will need to 
install and wire in a knock sensor. (The 99-05 cars 
have one from the factory and no additional work 
is required, so you can skip this step.) The knock 
sensor itself replaces the upper front mount ing 
bolt on the passenger side motor mount. Remove 
the 10mm bolt in the upper forward cor ner of the 
motor mount. Replace this bolt with the sup plied 
adapt er bolt and tight en to 20 ft/lbs. Fasten the 
knock sensor to the adapter with the supplied 
8mm allen bolt. Tighten this bolt to 12 ft/lbs, us-
ing Locktite on the threads. TORQUE CARE-
 FUL LY! Next, there is a long coaxial flying lead 
that comes out of the Hydra adaptor harness. Run 
this through the firewall at the main harness port on the passenger side. Once it is through and 
run down to the knock sensor, attach the 2 wire "injector" plug to it- one end goes to the main 
inner wire of the coaxial lead, and the other attaches to the shielding after you peel back the 
insulation and twist the shielding into a rope with your fingers. Finally, plug the har ness onto 
the knock sensor- it will snap in. Use ties to secure the wiring appropriately.

Wideband Oxygen Sensor. The wires for the Wideband O2 sensor will need to be run and the 
sensor calibrated. First, plug the 5 wires into the appropriate locations in the Hydra harness. 
(See diagram on the next page, and also on page 17 of Hydra's manual if you need more info.) 
Notice the plastic plug in the WBO2 harness has letters to indicate each wire. You will notice 
the 3 plugs on the Hydra harness are numbered as well, but may be referred to in one of two 
ways per the diagram below (A-F is in the picture, not stamped on the plugs). Attach the wires 
in the following locations by removing the retaining clip and sliding the pins into the appropriate 
hole until they click in:

WBO2 A->Small grey F1/B1
WBO2 B->Small grey F2/B2
WBO2 C->Small grey F9/B9
WBO2 D->Small grey E11/A11
WBO2 E->Large blue D7/D7

Triple check your work here! Replacement sensors are $275 and the heater 
element is delicate! Also, when you insert the pin, make sure that its up/down orientation is the 
same as the pins around it. 
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The WBO2 sensor itself now needs to be calibrated and installed. Free air calibration is cov-
ered starting on page 46 of Hydra's manual. Until that is done, run everything to where it needs 
to be, but leave the sensor itself in free air and unplugged from the harness. For installation, 
the best way to get the sensor under the car is to run the harness down under the shift boot. 
If you have a FM turbo kit, there will be an extra bung for the WBO2 already in place in the 
downpipe just before the catalytic converter. If you have something else, you will need to weld 
in a bung- we have them available. Make sure the sensor is as perpendicular as possible so 
that condensation does not pool in the sensor tip. Also, the WB needs to be at least 18" from 
the turbine outlet (or after the collecter on non-turbo cars), and still in front of the catalytic con-
verter. Since it is using Lambda and VE tables (instead of AFR values), the 2.6 platform now 
can autotune & run closed loop during idle using the WBO2. Note- in 96-05 OBD-II Miatas, the 
rear factory O2 sensor (post-cat) is not wired in with the Hydra. Remove it and plug the hole or 
it will fail. You can pull the harness through the body & stash it under the carpet.

99-00 Engine Swap (optional). If you are using a 99-00 intake manifold in a 90-97 chassis 
you will have to run the wires for VICS. Locating its solenoid, one post will go to switched 12v 
and the other needs to go to A11 (small blue, top row) in the Hydra harness. If you have a 94-
97 car the PRC wires already go to 12v and A11, however the Hydra doesn't control PRC (hot 
restart fuel control solenoid) so just run those two wires to the VICS solenoid and you're done. 
Finally, while online you'll have to go to Settings 1 -> Output Configuration -> Output PWM 12 
Function and select User 2. Click Enter. Next, also under Settings 1 go to User Logic using the 
drop down menu and for User 2 Type select "Engine Speed RPM <". Click Enter. Finally, to 
the right of that under User 2 Variable enter 5250 and click enter. Now, your VICS will pull to 
ground & activate when the RPM is less than 5250. Note- The switchover RPM can be opti-
mized on a dyno. Do one run on, one run off, and set the RPM where the lines cross.

Trim Map Switch (optional). If you're not using a Hydramist system (which automatically 
activates your trim maps) you can still set up a trim map switch so that you can make differ-
ent maps for different octanes or fuel types. Your base fuel, timing, and AFR target tables (for 
pump gas) are normally active. When you flip the switch, your fuel and timing trim maps will 
be overlaid onto your respective base maps, and your Aux AFR target map will replace your 
base AFR target map. Note- if you're using this to switch fuel types (for example from gasoline 
to E85), you should probably switch your software to display Lambda and not one specific fuel 
type. Tools -> System Tools -> Preferences -> Fuel Type. Lambda = 1 is always stoichiometric.

You will need to request a Hydra ECU pin from us, which you will attach to a wire and pin in to 
the Hydra harness at C7 (large blue plug, top row, position 7). You will run this wire to a switch, 
which you will mount wherever works for you. You will run a wire from the other post of the 
switch to a chassis ground.  When the ground breaks at the switch, you will be on your base 
maps.  When the ground makes it to the Hydra through the switch, your trim maps will be ac-
tive. (You can monitor this by going to View -> Inputs. See page 294 of Hydra's manual.)  Fi-
nally, you need to tell the software what to do. Go to Settings 2 -> Aux Input Configuration. For 
AUX8 (ISCB) Configuration select Auxiliary Maps Low and click Enter. (Starting on page 236 of 
Hydra's manual.) Now you can tune your Aux map groups as appropriate.

LS3 Coil Conversion (optional). The Miata runs its stock coils in batch (waste spark) ignition. 
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While the factory coils are good for most applications, in high boost cars they can run out of 
steam. An excellent upgrade in these situations is to upgrade to full sequential ignition using 
the much stronger individual coils from the GM LS3 engine. FM has a complete kit including 
coils, brackets, harness, wires, instructions, etc.- see http://www.flyinmiata.com/ for details.

Upgrading from Hydra 2.1 or 2.5. 1) All years- In your Hydra harness, there is a diode be-
ween A2 and A10 on the top row of the small blue plug.  Remove it- 2.6 has And/Or functions 
under Settings 2 that negate the need for this. In the software you'll go to Settings 1 -> Output 
Configuration. In Output PWM9 Function, you will change this to User 13 and click Enter. Exit 
that screen and go to Settings 2 -> User Logic (2xOR, 4x AND). For User 13A (OR) Type set 
Coolant Temp > and click Enter, and set User 13A (OR) Variable to the temp you want your 
secondary fan to come on at. For User 13B (OR) Type set it to Aux 3 V < and click Enter, and 
set User 13B (OR) variable to 3.0 and click Enter. Then, with the car running, confirm that 
the AC fan comes on with temperature or with activation of the A/C (with the fan speed on all 
speeds), and confirm that the A/C compressor comes on with the A/C switch.

2) 01-05 cars, except MSM. 2.6 no longer runs VVT on a RPM / Load spread map.  It now has 
its own standard map which is covered later in this manual. To activate this map, go to Set-
tings 1 -> Output Configuration -> Output PWM 2 Function and change this to Linear VCT, and 
click Enter. Next, also in Settings 1, go to Ignition and RPM Limits. On the right hand side click 
VCTi1 Enabled, VCTi1 Linear, and click the enter box to the right. Finally, if you go to Tools -> 
FIle Tools -> Import Map Fragment, you ~can~ select your old 2.1 or 2.5 map as the donor and 
import 3D Engine Calibration -> Intake VCT Target. The Hydra will port your old PWM Map 11 
into the new Intake VCT Target table. HOWEVER- THE SCALING IS DIFFERENT! See the 
description of VVT later in this manual. Therefore we recommend starting with a new FM VVT 
base map. 

3) The dwell in 2.6 runs a little hotter for some reason. We've had to reduce the values in the 
2D Engine Calibration -> Dwell map from -1 to -2 mS across the board to account for this. 
If your dwell output is too hot, you will feel misfires as you rev out to redline while staying in 
vacuum or boost. If your dwell was too cold, you may only get a misfire in boost.

Setting up the ECU

Re-attach the negative battery terminal. After you have completed the hardware installation it 
is time to perform the initial setup & calibration procedures in the software. The Windows XP 
software installation is covered starting on page 19 of Hydra's manual. Note- 2.64 r8 and later 
software is Vista compatible. Windows 7 is not officially compatible, but we hear it works.

Map Editing & Navigation. Starting on page 64 (3D maps) and 75 (2D maps) of Hydra's 
manual is everything you need to know about navigating your maps. 

Open Your Map. All Hydras shipped from FM come with a custom base map programmed into 
the ECU. (Page 40 of Hydra's manual.) This map is not however in the CD supplied software! 
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Therefore, we recommend you open this file from the ECU using the software, and save it in 
your Nemesis directory (C:\Program Files\nemesis ) as "template.s26". This will overwrite the 
non-Miata base map that comes in the software package. Also, when you open the Hydra soft-
ware it will now automatically come up with the last map you saved. Since all online changes 
in 2.6 are now made in real-time, after your initial setup the only time you'll need to upload & 
download is when you're doing fuel autotuning, which will be described later. 

Notes- a) The base map programmed into your ECU prior to shipping at FM has settings as 
appropriate for your car. The settings in the screen shots in either manual are not necessarily 
correct for your setup. b) When you key on 01-05 cars after installing the Hydra you will get a 
"blinky key" light.  This is the immobilizer function in the factory ECU. It is not an operational 
issue- you can simply remove the light bulb from the instrument cluster. c) If you're using a Se-
rial -> USB converter cable, you'll want to run a Fast Verify from ECU after making changes to 
your map and visually verify your maps. We have seen glitches (spikes) in 3D maps from using 
these converters. For best results, use a laptop with a Serial port. 

In the Hydra software Options menu, make sure to select the correct COM port for your PC be-
fore trying to connect to the Hydra! The default is COM3, and almost no one uses that port. If 
you're on a straight serial cable it is probably COM1. If you're using a USB -> serial converter, 
after loading in its drivers & plugging it in you'll need to go to your desktop and a) right click on 
My Computer b) click Properties c) click Hardware d) click Device Manager e) click on the + 
next to Ports (COM & LPT) and read which communications port the converter cable is on.

Throttle Position Sensor Calibration. Next, you need to calibrate your Throttle Position Sen-
sor for closed throttle and WOT. This is covered starting on page 44 of Hydra's manual. Failure 
to do this may cause the car to not go into closed loop idle, and the idle will hang high. If you 
notice your values floating after initial calibration you may need to replace your TPS.

WBO2 Calibration. The procedure for setting up the Zero cal & Gradient cal is covered start-
ing on page 46 of Hydra's manual. Note that when setting Zero cal, the relationship is actually 
inverse- Hydra's manual has a typo. Keep in mind that during calibration the sensor will get 
very hot- so be careful! When these steps are complete you can remove the key from the igni-
tion. Install the WBO2 sensor in the exhaust pipe once it has cooled down. Note- as the sensor 
ages it is a good idea to repeat the free air calibration procedure. You can easily check to see 
if it is way off- your AFR (WBO2) should read around 14.7 when your O2 (NBO2) left bank is 
dithering between 0-1 (assuming it is still in the car). 

Hint- as you make alterations it is a good idea to save the files so you have a running log of 
changes. This way, if an error occurs you always have a place to go back to. 

More info on maintaining the WBO2

The system voltage does make a difference when calibrating the WBO2- if it is too low it won't 
calibrate properly.  Also, if it's over 14.8v, the WBO2 heater circuit will shut down. Therefore, 
it will be calibrated to free air most accurately when the car is running and you are at normal 
system voltage. This means that you will need to plug the sensor hole with a bung plug and do 
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something to keep the exhaust from blowing back around the sensor while the car runs. If you 
can't start the car, make sure the system voltage is above 12v.

The NTK lab grade WBO2 that the Hydra comes with isn't as robust as the commercial grade 
Bosch LSU units used in many other aftermarket WBO2 setups, however it is more accurate.  
Therefore, you have the option of removing the WBO2 and switching back to the factory NBO2 
for daily driving after doing all your fuel tuning and getting your fuel map right where you want 
it. The downside to this is that the transition into boost usually isn't as smooth with the NBO2 
when it transitions from closed loop to open loop. The NBO2 does have short term (Closed 
Loop Enable, STT Left) and long term (LTT Enable, LTT Table) fuel trims, so as long as your 
fuel map is internally consistent it will move it around as necessary using these trims as tem-
peratures and pressures change. Your other choice would be to run the WB full time and be 
OK with maybe having to replace the sensor from time to time at $275 a pop. We honestly 
don't know what to expect for a lifespan- it depends on a lot of things. Hydra says they have a 
lifespan of around 500-800 hours on turbocharged cars. Keep in mind that if it does start to fail, 
the ECU will have no idea and will continue to trim as if it were a good signal. A failing WBO2 
sensor will have an output that is not responsive to changes in throttle input, up to the point 
where it is dead and the output completely flatlines- you will want to monitor for this. Typically 
it flatlines at stoichiometric. (This means when you go into boost it will always try to add closed 
loop fuel.) Our preference is to just run the WBO2 full time and keep an eye on it. 

Switching from WBO2 to NBO2.  The base map comes set up for the Wideband O2 sensor. 
(linear 0-5v, 5 wire) We do recommend leaving your factory primary narrowband O2 sensor 
(non-linear, 0-1v, 1 or 4 wire) installed so you can a) reality check the WBO2 calibration since 
the NB will only effectively tell you stoichiometric (14.7 for gasoline) or b) switch back to the NB 
if the WB dies, or you just want to remove the WB since it won't last forever.  

To switch you'll do the following: 1) In Settings 1 -> Closed Loop, change your left module sen-
sor source to EGO Left and click Enter. Change your right module sensor source to EGO Right 
and click Enter. Check the LTT (long term trim) Enable box & click enter. 2) In 2D Closed Loop 
-> Closed Loop Upper TPS Limit you'll want to determine what TPS (throttle position sensor) 
value (%) gets you to around 75 kPa and set this value here. Since the NBO2 can only effec-
tively trim stoichiometric, and you only want to run there under idle, cruise, & light accelera-
tion, you want closed loop to go open any time you start to accelerate the car into any kind of 
power. Using a TPS limit is simple & effective. 3) Go to View -> LTT Table and clear the table. 
You are now running NBO2 closed loop at idle & cruise, and open loop under acceleration. The 
LTT function will ensure that the open loop parts of the fuel table will adapt to changes in atmo-
spheric conditions- this is how most factory ECUs run.

Note- the only times you would run Open Loop (no O2 sensor feedback at all) are a) if you had 
a failed O2 sensor causing the car to run poorly, b) if you are dyno tuning and want to see your 
A/F ratios and injector pulsewidth straight as they are in the map without any O2 closed loop 
trim applied, or c) if you have a well tuned track-only race car. 
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Initial ECU Tuning

Idle Fuel. (Refer to the section beginning on page 49 of Hydra's manual for general startup 
info.) Start the car and let it idle. Once it is warmed up, if it is obviously rich (spitting) or obvi-
ously lean (hunting or stalling) you'll want to make an initial trim to the idle fuel areas (3D Fuel 
Calibration -> Base Fuel Table) to get it smoothed out. The fuel and timing map that you were 
provided is based on cars tuned at FM with similar setups to yours, so it should get you go-
ing. If you have a custom setup, your fuel map should be pretty close assuming that we knew 
about it before we shipped you the ECU.  If the car will not start, check for voltage (large blue 
plug, C1 & D1), fuel, & spark first, then call one of our techs for assistance.

Idle Speed.  Once the car is idling smoothly you'll need to set your idle speed. Take note of 
your current idle speed, and also of your ISC %. (Real-time info on the right of the computer 
screen.) Locate the idle air bypass screw on the side of your throttle body- it's inside a sheath. 
The default ISC settings (Settings 1 -> Idle Speed Control) have proven pretty stable in many 
cars, so start by seeing if you can get your idle speed in line by simply rotating your idle air by-
pass screw until your idle speed is in the 900 RPM range. (1200 for supercharged cars)  In the 
real-time ISC % you're looking to see 20-35% with the fans & A/C off. If rotating that screw in 
does not reduce a high idle, and your ISC % is bottoming out, the car most likely has a vacuum 
leak that you'll need to fix before proceeding. If your idle speed is low, and changing your ISC 
Max Duty or ISC Min Duty (main Hydra manual, pgs 170-173) does not affect your idle speed, 
you may have a bad ISC motor. As a diagnosis, try unplugging the ISC from the harness and 
see if anything changes.

The other variable in the ISC screen worth mentioning is the ISC Max Vacuum. Once the car is 
warmed up, if you come to a stop and the idle hangs high you'll want to raise this number. (Try 
5-10 points at a time.) If you come to a stop and the idle droops or the car stalls, you'll want 
to lower this number. (This assumes that your TPS is properly calibrated.) If you travel some-
where with a big elevation change you may need to work this variable as well, same as you 
would your idle fuel mixture or your EBC. A good starting point is the number half way between 
your idle vacuum (in mmHg) and the vacuum that the manifold pulls under full deceleration 
from say 4000 RPM.

Base Timing. Once the car is idling smoothly with a reasonable AFR you'll need to set the 
base timing- that way what the ECU says for timing advance and what the car is actually doing 
are the same thing. We have seen some base timing variance when just strapping the Hydra 
onto a stock car, so this step must be done. Setting the base timing will require a timing light. 
With the car running and at a smooth idle, look at the top of the real-time number display on 
the left of the home screen. The box labeled "ADV" is your ignition advance output in degrees, 
according to the ECU. This value is determined by taking the value from the ignition map and 
applying to it any trim as defined in your air and water temperature spark compensation tables. 
Next, under the hood of the car hook a timing light up to the #1 plug wire and flash the light at 
the timing marker (around 1-2 o'clock) on the main (crank) pulley. What we want to see is the 
following: the timing marker on the pulley (the passenger side notch if there are two markers- 
on a left hand drive car) lines up with the value on the backing plate that corresponds to the 
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displayed ADV reading, in real-time (online mode). If it does not, you will need to adjust your 
base timing. 

For example- if the value in ADV is 10, it makes the procedure easy. If your main pulley has 
one timing notch (90-93), we want this notch to line up with the "10" on the backing plate. If 
your main pulley has two timing notches (94-05), you want the (LHD) passenger side notch to 
line up with the "10" on the backing plate. If the value in ADV is more or less than 10 you will 
use the idea behind the procedure in the last sentence while making sure the backing plate 
marker value that you line the timing notch up with is the same as the value you see in the 
ADV screen. Note- each notch on the backing plate is 2 degrees! Therefore, if the ADV value 
says 12, line the appropriate timing notch up to the notch on the backing plate one left of the 
10 marker (as seen standing in front of the car).  If it says 9, line it up in-between the 10 and 
the next notch to the right. The following explains how this is done electronically, in the soft-
ware.

Reference Angle. (See page 163 of Hydra's manual.) Adjustments to your base timing will be 
made in the Timing Reference Angle box under Settings 1 -> Ignition Triggers. Lowering this 
number will advance the base timing and raising the number will retard it. Alter this number as 
necessary and re-check it with the timing light until the ADV value matches the pulley value. 
Once it matches, the base timing is calibrated. 

For 90-97 cars you may run out of adjustment in Timing Reference Angle (There is a floor and 
a ceiling) and will have to rotate your Cam Angle Sensor to get it back in range. To do this, 
loosen the 12mm bolt that locks the cam angle sensor (CAS) in place and rotate the sensor 
until the timing marker on the pulley lines up with the appropriate marker on the backing plate. 
Remember to re-tighten when finished. The CAS is at the back of the head: behind the intake 
cam for 1.6L engines and behind the exhaust cam for 1.8L engines. 

Fuel Autotuning

Hydra 2.6 has incorporated Volumetric Efficiency (VE) tables into its autotuning procedure, 
which makes autotuning your fuel map much faster and smoother. The procedure however is 
more complex. Since all FM Hydra packages come with the WBO2, you (the original owner) 
have already purchased the license to use the WB Autotuning feature on up to 2 computers. 
(If you are not the original owner, or if you need 3+ license keys, they are $100 each.) The first 
step is to unlock the autotuning feature. Go to Tools -> Activate Feature -> Learn Data. (Page 
291 of Hydra's manual.) Here you will see your Machine ID. You will need to email that number 
to us, and after processing through Hydra we will provide you with a Feature Activation Key 
which you will enter into the software. (You should only do this with the laptop computer that 
you use for tuning since the number of keys you are allotted are limited.)

Your pre-programmed base fuel map can be found in 3D Fuel Calibration -> Base Fuel Table. 
Note- your base fuel table displays values in milliseconds of injector on-time. After you get 
your car running & idling, you'll perform the following procedure to set it up for autotuning.  
First, you'll want to restart your laptop & re-upload the map from the ECU. If you don't do this 
sometimes autotuning doesn't track in real-time and nothing happens. (Note- you'll also need 
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to have the latest version of Java installed.) Then, go into Settings 1 -> Closed Loop Control 
and un-check Closed Loop Enable. (Always click Enter when you make a change online to 
store it to the ECU.) Below that on your Left & Right Module Sensor Source you'll need UEGO 
AFR Target selected for both.

Next, also under Settings 1, go to Setup Options. For the Injector Flow variable enter the size 
of 1 injector and click enter. (Most FM kits come with 550cc injectors.) For the Cylinder Capac-
ity variable enter the size of 1 cylinder and click Enter. (stock 1.8 engines are 1840cc / 4, and 
stock 1.6 engines are 1597cc / 4. Oversize pistons add roughly 40cc per millimeter oversize. 
You can now exit the Settings screen.

Next, you will need to get offline by going to Comms -> Disconnect. Go to 3D Calibration -> 
VE. Then go to Tools -> Migration Tools -> Fuel Base Table to VE. (Page 290 of Hydra's manu-
al.) This generates a working VE table. (Migration Tools will not come up when you are online.)  
Now, save this map, and then get back online through the Comms menu. Go to File -> Save to 
ECU and wait for it to save. Now, your VE table is in your ECU. Note- this step is already done 
in the base map with most FM kits.

Next, go to Settings 1 -> Setup Options. (Remember, you're back online now.) Check VE Mode 
Enable and click Enter. Now, your ECU is running injection off of your VE table and not your 
base fuel table. You can exit the Settings screen. Make sure you're in the 3D Fuel Calibration 
-> VE table and go to Tools -> Tuning Tools -> Learn Data. This brings up a half-size screen 
where it automatically makes changes based on the Lambda error to the VE table. (Starting on 
page 276 of Hydra's manual.) The yellow circles denote the zone(s) that it is currently tuning. 
When you're done tuning click OK, and it will import the changes to your VE table. If it obvi-
ously missed any spots (big dips or spikes) go ahead and smooth them out by hand to match 
the spots it did tune- this will improve drivability. Note- while this method tunes idle & cruise 
very well, it's not so effective at full throttle tuning due to how little time you'll spend in any one 
zone. It is still advised to do your full throttle tuning while running open loop on a Dyno. 

When you're done tuning your fuel you'll first need to get back offline. Go to Tools -> Migration 
Tools -> VE to Fuel Base Table. This takes the VE changes and makes you a new base fuel 
table that is more precise than the one you started with. You'll then need to save the file, get 
back online, and Save to ECU. (Once again, because you can't get into Migration Tools while 
you're online.) Now you'll go to Settings 1 -> Setup Options and un-check VE Mode Enable, 
and click Enter. Finally, go to Settings 1 -> Closed Loop Control and check Closed Loop En-
able and click enter. This will put you back on closed loop mode running from your new base 
fuel table.

Tech note- The maximum number of milliseconds that can be injected into the engine at any 
given engine speed is defined in the equation [120 / thousand RPM]. Therefore, for a 7500 
RPM redline the time available is 120 / 7.5, or 16 milliseconds. If the base fuel plus any added 
trims exceed this amount at that RPM, the additional fuel will not richen the AFR. Also take 
note that the Hydra reads a conservative injector duty cycle- 100% in the 2.6 Hydra is really 
around 80-85% in actuality. Therefore, you can tune your fuel out to 100% in the Hydra real-

time screen.
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Going Full Throttle & Knock

Boost Control for Turbo cars. We recommend getting the car dialed in on base boost before 
increasing the boost with EBC or MBC. Until you're ready you'll want to leave Settings 1 -> 
Output Configuration -> PWM 3 turned Off if you're using EBC. When you're ready for EBC, 
you can switch this output from Off to PWM Map 2, which will activate the link to EBC. Then, 
you can go to 2D PWM -> PWM Map 2 and tune your boost level using the curve in that map. 
Make sure to leave 0 at 0 or the solenoid will run when the car is off boost. Note- if your atmo-
spheric conditions change significantly and you then experience lower or higher boost levels, 
you may need to go re-tune your PWM Map 2 for the current conditions.

Knock Threshold. When you are ready to boost go to 2D Engine Calibration -> Knock 
Threshold. Here you will see a stream of little white "x"s that represent the real-time voltage 
output from your knock sensor, as well as your threshold line. Note- the stream has a limit, so 
when you reach it the oldest "x"s will fall off. The threshold level is user adjustable & should 
be calibrated. The way to set it for your car is to monitor the "x"s while you rev the engine out 
to redline while staying deep in vacuum (less than 10" on your boost gauge). Without load 
there won't be knock. Therefore, any "x" activity is engine noise.  Set your threshold at a height 
above this noise level that occured during this test. Then, it is reasonable to assume that any 
"x" outlying from the group while driving under load will be knock. 

Tuning Your Timing

The timing table that came with your base map was developed using cars tuned at FM on 91 
octane gas. The off-boost spark timing is pretty good- there is no real reason to change it un-
less you have an exhaust gas analyzer and wish to dial it in for emissions. The on-boost timing 
can be tuned on the street using datalogging, or optimally on a Dyno. Note- if you are in the 
Spark screen and a zone turns red, you have exceeded your knock threshold in that zone!

Datalogging. The best way to tune your timing (and everything else, really) is by running a 
datalog of the car being driven and then analyze the data after the fact. While it is best to do 
this on a dyno, it is possible to do datalog based tuning on the street if it can be done in a safe, 
legal manner with a passenger running the laptop. The Hydra's datalogging functions are cov-
ered starting on page 264 of Hydra's manual.  While driving and online, go to Tools -> Tuning 
Tools -> Log Data. Choose what variables to log, and pick colors for their traces. (The lighter 
colors are easier to see.) When you are finished, go to File -> Export Raw Log. This will save it 
in the native format for the program. From there, you can review the log and tune as appropri-
ate. You can also send the log along with a current .s26 (map) file to us for review.

Note- when opening up a .s26 Hydra map file, do not do it by double clicking the file in Win-
dows. Always do it through the Hydra program.

We recommend that if you are not experienced with tuning standalone ECUs that you 
hire a qualified professional to do it for you. Optimization in many aspects is key to a 
good experience and a safe, reliable car. The tech department at FM can assist you re-
motely to a certain degree-  feel free to call or email us if you have any questions.  



16

Closed Loop Alternator Control (99-05)

While the 90-97 cars have voltage control built into the alternator, the 99-05 cars have ECU 
regulated voltage control. This means that the Hydra is responsible for maintaining a set volt-
age range within the system. If in your 99-05 car your system exceeds 15v, your Brake & ABS 
lights on the dash will come on and the radio will cut out. Note- the Hydra software will not read 
over 15v! This means that your system voltage could be dangerously more! If this occurs, go 
to 2D PWM -> PWM Map 1 Duty. This is your closed loop alternator control gain map. Observe 
what zone the real-time yellow bar is in when the over voltage occurs. Lower that section of 
the map until the voltage stabilizes between 13.8-14.2v (hard coded target) when in that zone. 
Remember, a smooth map is always better than a rough one so you should also smooth the 
adjacent zones. Note- if you ever notice your system voltage dropping below 13v, go through 
the same procedure except raise the correlating zone until your voltage stabilizes between 
13.8-14.2v. However, if the voltage goes low when you introduce electrical load and at the 
same time the yellow bar goes most or all the way to the right of the curve, it is a good indica-
tion that your alternator is bad. Keep in mind that a 94-97 internally regulated Miata alternator 
will bolt on to a 99-05 car and work with a couple wiring changes, negating the need for ECU 
alternator control. Contact FM for instructions on how to set it up if you'd like to do this.

Variable Valve Timing (01-05, except MSM)

On 2001-2005 Miatas (except MSM) there is a hydraulic assembly on the intake cam that al-
lows for real-time adjustable cam timing between two end points based on a 3D map. Having 
control of your valve overlap is an excellent tool- it allows for the user to realize optimal flow 
rates for both cruise and full throttle. Without this there is always some compromise involved in 
cam timing. Warning- improper cam timing can cause increased EGTs, detonation, and also 
bent valves in interference engines. This variable is not for the amateur tuner! This is a pow-
erful tuning tool that can have an even greater effect than fuel & timing fine tuning.  Note- all 
Miata VVT engines are non-interference from the factory.

To access the cam map, go to 3D Engine Calibration -> Intake VCT Target. In this map you set 
the amount of intake cam advance in relation to the "off" position of full cam retard. Note- stock 
Miata engines are non-interference. If you have a head shave, aftermarket pistons, high lift 
cams, or oversized valves you need to determine if your engine has become an interference 
one. If so, incorrect tuning of this map (too much advance) could put a piston into a valve! If 
you have an interference engine, or are not sure, set this entire map to -35 before start-
ing your car for safety and carefully dyno tune your VVT map while listening for interfer-
ence.

When the car is off, or when the VVT solenoid is unplugged, the intake cam locks to full re-
tard (counter-clockwise) with a spring & peg. When the oil pressure goes up & the VVT map 
commands it, the oil pressure comes through the solenoid, overpowers the spring & peg, and 
allows the cam to advance (clockwise) as requested. Full retard is usually around -33. So, to 
ensure it doesn't try to advance the cam until there is sufficient oil pressure in the system to 
control it (this varies by car), we have set the base map to go to -35 at all RPM values below 
where there is sufficient pressure, including idle. In most cars the pressure comes up around 
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2500 RPM. Full cam advance is around +12.5 on our test car, so that puts the "zero" point of 
the cam around -10.5.  

Fortunately there is an easy way to test the total range in your car & calibrate the FM base 
map if you have a non-interference motor. While in the Intake VCT Target window, press the 
letter "z" 9 times.  This will bring up the real-time cam advance monitoring screen. In there you 
can monitor where your cam advance actually is (and see if VVT is working when you rev the 
engine). Therefore, you can go to obviously low and obviously high numbers in the VCT Target 
Table, return to the monitoring window, and see where your real-time retard or advance (re-
spectively) limits out by watching the VVTi1 target & actual readings.  This is your maximum 
potential cam advance / retard range.  In order to calibrate the VVT base map to your car, 
you'll highlight the entire VVT target map & adjust it in unison such that your idle value is the 
same as the fully retarted limit as seen in the "z" screen.

For idle and low RPM, there is not enough oil pressure in the system to reliably hold advance 
in the cam gear, and therefore you should leave the value in the chart at full retard (wherever 
it calibrates) so that it does not even try to advance the cam. Trying to advance it can result in 
a bad idle or jerky drivability. This poor behavior can come from a few different things including 
the VVT (or the AFR being lean), so if you experience it, you can rule VVT in our out by simply 
unplugging the connector from the solenoid (front / top of intake cam on the valve cover) and 
see if the problem goes away. If it does, try holding the fully retarded limit to higher in the rev 
range before you allow any cam advance. Remember, when you're done tuning this map make 
sure that the transitions points are smooth- large, fast changes to the cam advance under load 
can damage the valvetrain in the long run and cause poor drivability.

Note- You can retrofit a VVT head or engine to a non-VVT 1.8. It is a lot of work, but it may be 
worthwhile for your project. Contact FM for the VVT wiring & Hydra settings info you'll need.

Hydramist Water Injection (optional)

Element Tuning in conjunction with Aquamist has designed a water injection setup that is fully 
integrated into the Hydra Nemesis system. It works very well.  FM offers this system- please 
contact us for any more information or to order.

Be safe & have fun!


